WordPress 5.2正式英文版Jaco已经发布

虫子君
虫子君
虫子君
559
文章
260
评论
2019年5月8日14:05:01 1 959 977字阅读3分15秒

今天虫子君上班的时候一大早看到,WordPress的升级提醒,此次更新的是WordPress5.2版本,版本名称为“Jaco”,寓意为纪念著名已逝的贝斯手“Jaco Pastorius”,可以直接在WordPress的“仪表盘”当中下载更新。

如果更新中出现错误,此次更新更新的新功能中,可以更加容易的修复您的网站,当然,除了这些还有一些强大的工具供您使用,以便于为您修复一些相对致命的错误,不论您是给自己的网站使用还是给企业客户,都能够相比以往更加轻松的管理您的网站。

WordPress 5.2正式英文版Jaco已经发布

提示:如您更新失败,可以在虫子君的博客当中查找相关的文档,以便于为您妥善解决WordPress安装时遇到的问题。

即时健康检查

基于 5.1 中引入的站点运行状况功能,此版本添加了两个新页面以帮助调试常见配置问题。它还增加了开发人员可以为站点维护人员提供调试信息的空间。

PHP 错误保护

这种以管理员为中心的更新可让您安全地修复或管理致命错误,而无需开发人员时间。它具有更好的处理所谓的“死亡白屏”,以及一种进入恢复模式的方法,它可以暂停导致错误的插件或主题。

对每个人的改进

辅助功能更新:许多变化协同工作,以改善使用屏幕阅读器和其他辅助技术的人的上下文感知和键盘导航流程。

新的仪表板图标:十三个新图标,包括 Instagram,BuddyPress 的一套图标,以及全球包含的旋转地球图标。在仪表板中找到它们并享受一些乐趣!

插件兼容性检查:WordPress 现在将自动确定您的网站的 PHP 版本是否与已安装的插件兼容。如果插件需要比您的网站当前使用的更高版本的 PHP,WordPress 将不允许您激活它,以防止潜在的兼容性错误。

开发者的福利

PHP Version Bump:支持的最低 PHP 版本现在为 5.6.20。从 WordPress 5.2 *开始,主题和插件可以安全地利用命名空间,匿名函数等等!

隐私更新:新的主题页面模板,条件函数和两个 CSS 类使得隐私策略页面的设计和自定义变得更加容易。

新的body 钩子:5.2 引入了一个 wp_body_open 钩子,它允许主题支持在<body>元素的开头注入代码。

构建 JavaScript:通过在 wordpress / scripts 包中添加 webpack 和 Babel 配置,开发人员不必担心设置复杂的构建工具来编写现代 JavaScript。

 

下载信息 软件名称:WordPress Jaco(5.2)
下载地址 查看演示
展开全文
  • 您有好资源需要让广大网友一起享用吗?可以是您的主题,也可以是插件,欢迎来投稿!
  • 这里是我的博客,亦是您分享插件或主题的地方,虫子君只专注WordPress,以及自己的工作。这里欢迎你来投稿。

您必须才能发表评论!

评论:1   其中:访客  1   博主  0
    • avatar ‐Y/oung. 0

      将的真好,还居然自带翻译的。